hplip>=3.20.3-2 への更新は対応作業が必要です

バージョン 3.20.3-2 より古い hplip パッケージはコンパイル済みの python モジュールが欠けていました。これはバージョン 3.20.3-2 で修正され、自動生成された追跡されない .pyc ファイルを更新時に上書きする必要があります。更新時に以下のようなエラーに遭遇した場合、

hplip: /usr/share/hplip/base/__pycache__/__init__.cpython-38.pyc exists in filesystem
hplip: /usr/share/hplip/base/__pycache__/avahi.cpython-38.pyc exists in filesystem
hplip: /usr/share/hplip/base/__pycache__/codes.cpython-38.pyc exists in filesystem
...many more...

以下のコマンド

pacman -Suy --overwrite /usr/share/hplip/\*

を使用して更新を行ってください。