Perl が 5.20 にアップデートされました

Perl 5.20 になったので、新しい perl バージョンがリリースされたいつも通りに、純粋な perl コードではないモジュールは全てリビルドする必要があります。公式リポジトリにあるパッケージは全てリビルド済みです。

ここ最近のメジャーアップデートでは、別のバージョンでビルドされたモジュールをロードしようとするとエラーメッセージが表示されます。5.20 ではセグメンテーション違反が発生します。カスタムインストールした CPAN モジュールと libperl.so にリンクされているバイナリを全てリビルドするようにして下さい。

エラーが発生するパッケージを簡単に見つけられるスクリプトを arch-dev-public に投稿しています。